// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((^(\\\\).*)$)|((^[a-z]|[A-Z])[:][\\].*)$").unwrap();
let string = "\\\\mainnt\\common\\public common\\bdelamater
C:\\asdasdasd\\asdasd
c:\\asdklajsdlkajsd
0:\\abc
ancC:\\lkasjdlkajsd
asdasd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}