re = /((^(\\\\).*)$)|((^[a-z]|[A-Z])[:][\\].*)$/m
str = '\\\\mainnt\\common\\public common\\bdelamater
C:\\asdasdasd\\asdasd
c:\\asdklajsdlkajsd
0:\\abc
ancC:\\lkasjdlkajsd
asdasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end