package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((^(\\\\).*)$)|((^[a-z]|[A-Z])[:][\\].*)$`)
var str = `\\mainnt\common\public common\bdelamater
C:\asdasdasd\asdasd
c:\asdklajsdlkajsd
0:\abc
ancC:\lkasjdlkajsd
asdasd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}