import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((^(\\\\\\\\).*)$)|((^[a-z]|[A-Z])[:][\\\\].*)$";
final String string = "\\\\mainnt\\common\\public common\\bdelamater\n"
+ "C:\\asdasdasd\\asdasd\n"
+ "c:\\asdklajsdlkajsd\n"
+ "0:\\abc\n"
+ "ancC:\\lkasjdlkajsd\n"
+ "asdasd";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}