#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:\d{2}[-.\s]?){5}\b"
Local $sString = "0231000000" & @CRLF & _
"02 31 00 00 00" & @CRLF & _
"02.31.00.00.00" & @CRLF & _
"02-31-00-00-00" & @CRLF & _
"0231123456789" & @CRLF & _
"02:31:00:00:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")