import re
regex = re.compile(r"\b(?:\d{2}[-.\s]?){5}\b", flags=re.MULTILINE)
test_str = ("0231000000\n"
"02 31 00 00 00\n"
"02.31.00.00.00\n"
"02-31-00-00-00\n"
"0231123456789\n"
"02:31:00:00:00")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")