import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(?:\\d{2}[-.\\s]?){5}\\b";
final String string = "0231000000\n"
+ "02 31 00 00 00\n"
+ "02.31.00.00.00\n"
+ "02-31-00-00-00\n"
+ "0231123456789\n"
+ "02:31:00:00:00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}