package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?:\d{2}[-.\s]?){5}\b`)
var str = `0231000000
02 31 00 00 00
02.31.00.00.00
02-31-00-00-00
0231123456789
02:31:00:00:00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}