re = /\b(?:\d{2}[-.\s]?){5}\b/m
str = '0231000000
02 31 00 00 00
02.31.00.00.00
02-31-00-00-00
0231123456789
02:31:00:00:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end