// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b(?:\d{2}[-.\s]?){5}\b").unwrap();
let string = "0231000000
02 31 00 00 00
02.31.00.00.00
02-31-00-00-00
0231123456789
02:31:00:00:00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}