using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?:\d{2}[-.\s]?){5}\b";
string input = @"0231000000
02 31 00 00 00
02.31.00.00.00
02-31-00-00-00
0231123456789
02:31:00:00:00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}