# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(http:\\/\\/[^\\/]+)?\\/(?!(?:sites|SitePages)\\/)(.*)$/\1\/sites\/\2/mg;t' <<< "http://intranet/global
/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/SitePages/default.aspx
"