#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(http:\/\/[^\/]+)?\/(?!(?:sites|SitePages)\/)(.*)$"
Local $sString = "http://intranet/global" & @CRLF & _
"/sites/global" & @CRLF & _
"/page/file.ext" & @CRLF & _
"/sites/other" & @CRLF & _
"/page.ext" & @CRLF & _
"/intranet/global" & @CRLF & _
"http://intranet/SitePages/default.aspx" & @CRLF & _
""
Local $sSubst = "\1/sites/\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)