using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(http:\/\/[^\/]+)?\/(?!(?:sites|SitePages)\/)(.*)$";
string substitution = @"\1/sites/\2";
string input = @"http://intranet/global
/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/SitePages/default.aspx
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}