$re = '/^(http:\/\/[^\/]+)?\/(?!(?:sites|SitePages)\/)(.*)$/m';
$str = 'http://intranet/global
/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/SitePages/default.aspx
';
$subst = "\1/sites/\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;