re = /^(http:\/\/[^\/]+)?\/(?!(?:sites|SitePages)\/)(.*)$/m
str = 'http://intranet/global
/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/SitePages/default.aspx
'
subst = '\\1/sites/\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result