import Foundation
let pattern = #"^(http:\/\/[^\/]+)?\/(?!(?:sites|SitePages)\/)(.*)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://intranet/global
/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/SitePages/default.aspx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1/sites/\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)