const regex = /^(http:\/\/[^\/]+)?\/(?!(?:sites|SitePages)\/)(.*)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(http:\\\/\\\/[^\\\/]+)?\\\/(?!(?:sites|SitePages)\\\/)(.*)$', 'mg')
const str = `http://intranet/global
/sites/global
/page/file.ext
/sites/other
/page.ext
/intranet/global
http://intranet/SitePages/default.aspx
`;
const subst = `\1/sites/\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);