# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([^(]+)(.*?;)(CAT.*)$/$1$2$1;$3/gm;t' <<< "aarhus(iof>city>thing,equ>arhus);CAT(CATN),N(NP) ;
abadan(iof>city>thing);CAT(CATN),N(NP) ;
abandon(icl>leave>do,agt>person,obj>person);CAT(CATV),AUX(AVOIR),VAL1(GN) ;"