package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^(]+)(.*?;)(CAT.*)$`)
var str = `aarhus(iof>city>thing,equ>arhus);CAT(CATN),N(NP) ;
abadan(iof>city>thing);CAT(CATN),N(NP) ;
abandon(icl>leave>do,agt>person,obj>person);CAT(CATV),AUX(AVOIR),VAL1(GN) ;`
var substitution = "$1$2$1;$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}