# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^([^(]+)(.*?;)(CAT.*)$"
test_str = ("aarhus(iof>city>thing,equ>arhus);CAT(CATN),N(NP) ;\n"
"abadan(iof>city>thing);CAT(CATN),N(NP) ;\n"
"abandon(icl>leave>do,agt>person,obj>person);CAT(CATV),AUX(AVOIR),VAL1(GN) ;")
subst = "$1$2$1;$3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.