$re = '/^([^(]+)(.*?;)(CAT.*)$/m';
$str = 'aarhus(iof>city>thing,equ>arhus);CAT(CATN),N(NP) ;
abadan(iof>city>thing);CAT(CATN),N(NP) ;
abandon(icl>leave>do,agt>person,obj>person);CAT(CATV),AUX(AVOIR),VAL1(GN) ;';
$subst = "$1$2$1;$3";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;