use strict;
my $str = 'aarhus(iof>city>thing,equ>arhus);CAT(CATN),N(NP) ;
abadan(iof>city>thing);CAT(CATN),N(NP) ;
abandon(icl>leave>do,agt>person,obj>person);CAT(CATV),AUX(AVOIR),VAL1(GN) ;';
my $regex = qr/^([^(]+)(.*?;)(CAT.*)$/mp;
my $subst = '$1$2$1;$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";