re = /^([^(]+)(.*?;)(CAT.*)$/m
str = 'aarhus(iof>city>thing,equ>arhus);CAT(CATN),N(NP) ;
abadan(iof>city>thing);CAT(CATN),N(NP) ;
abandon(icl>leave>do,agt>person,obj>person);CAT(CATV),AUX(AVOIR),VAL1(GN) ;'
subst = '$1$2$1;$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result