package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`("([^"]|\\")*[^\\]"|"")`)
var str = `"hello" world "this " is a t"Es"t
"how did it go?" "" jelly"h\nllo" "hello\"
I want you to match a ' [some stuff] then another '
But the last ' can't be preceded by a \
"this is my super sketchy string"
'-`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}