$re = '/("([^"]|\\\\")*[^\\\\]"|"")/';
$str = '"hello" world "this " is a t"Es"t
"how did it go?" "" jelly"h\\nllo" "hello\\"
I want you to match a \' [some stuff] then another \'
But the last \' can\'t be preceded by a \\
"this is my super sketchy string"
\'-';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);