re = /("([^"]|\\")*[^\\]"|"")/
str = '"hello" world "this " is a t"Es"t
"how did it go?" "" jelly"h\\nllo" "hello\\"
I want you to match a \' [some stuff] then another \'
But the last \' can\'t be preceded by a \\
"this is my super sketchy string"
\'-'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end