import Foundation
let pattern = #"("([^"]|\\")*[^\\]"|"")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"hello" world "this " is a t"Es"t
"how did it go?" "" jelly"h\nllo" "hello\"
I want you to match a ' [some stuff] then another '
But the last ' can't be preceded by a \
"this is my super sketchy string"
'-
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)