// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"("([^"]|\\")*[^\\]"|"")"#).unwrap();
let string = "\"hello\" world \"this \" is a t\"Es\"t
\"how did it go?\" \"\" jelly\"h\\nllo\" \"hello\\\"
I want you to match a ' [some stuff] then another '
But the last ' can't be preceded by a \\
\"this is my super sketchy string\"
'-";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}