import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"([^\"]|\\\\\")*[^\\\\]\"|\"\")";
final String string = "\"hello\" world \"this \" is a t\"Es\"t\n\n"
+ "\"how did it go?\" \"\" jelly\"h\\nllo\" \"hello\\\"\n\n"
+ "I want you to match a ' [some stuff] then another '\n"
+ "But the last ' can't be preceded by a \\\n\n"
+ "\"this is my super sketchy string\"\n\n"
+ "'-";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}