# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=<variable.*>.*)loves(?!(?<=\[[^][]*)[^][]*])(?=.*<\/variable)/hates/gm;t' <<< "<variable class=\"loves\">[loves] My dog loves dog food </variable>
<variable class=\"loves\">[loves] My dog hates dog food </variable>"