#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=<variable.*>.*)loves(?!(?<=\[[^][]*)[^][]*])(?=.*</variable)"
Local $sString = "<variable class="loves">[loves] My dog loves dog food </variable>" & @CRLF & _
"<variable class="loves">[loves] My dog hates dog food </variable>"
Local $sSubst = "hates"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)