import Foundation
let pattern = #"(?<=<variable.*>.*)loves(?!(?<=\[[^][]*)[^][]*])(?=.*</variable)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<variable class="loves">[loves] My dog loves dog food </variable>
<variable class="loves">[loves] My dog hates dog food </variable>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"hates"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)