using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<variable.*>.*)loves(?!(?<=\[[^][]*)[^][]*])(?=.*</variable)";
string substitution = @"hates";
string input = @"<variable class=""loves"">[loves] My dog loves dog food </variable>
<variable class=""loves"">[loves] My dog hates dog food </variable>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}