re = /(?<=<variable.*>.*)loves(?!(?<=\[[^][]*)[^][]*])(?=.*<\/variable)/m
str = '<variable class="loves">[loves] My dog loves dog food </variable>
<variable class="loves">[loves] My dog hates dog food </variable>'
subst = 'hates'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result