const regex = new RegExp('(?<=<variable.*>.*)loves(?!(?<=\\[[^][]*)[^][]*])(?=.*</variable)', 'gm')
const str = `<variable class="loves">[loves] My dog loves dog food </variable>
<variable class="loves">[loves] My dog hates dog food </variable>`;
const subst = `hates`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);