import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<variable.*>.*)loves(?!(?<=\\[[^][]*)[^][]*])(?=.*</variable)";
final String string = "<variable class=\"loves\">[loves] My dog loves dog food </variable>\n"
+ "<variable class=\"loves\">[loves] My dog hates dog food </variable>";
final String subst = "hates";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}