package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^https?:\/\/[^\/]+\/?(\?.*)?$`)
var str = `http://example.com
https://example1.com
https://example2.com/
http://anything.com/?test=12
http://anything.com?test=12
http://example.com/path
https://example.com/path1/path2
https://example.com/path1?test=123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}