import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/[^\\/]+\\/?(\\?.*)?$";
final String string = "http://example.com\n"
+ "https://example1.com\n"
+ "https://example2.com/\n"
+ "http://anything.com/?test=12\n"
+ "http://anything.com?test=12\n\n"
+ "http://example.com/path\n"
+ "https://example.com/path1/path2\n"
+ "https://example.com/path1?test=123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}