$re = '/^https?:\/\/[^\/]+\/?(\?.*)?$/m';
$str = 'http://example.com
https://example1.com
https://example2.com/
http://anything.com/?test=12
http://anything.com?test=12
http://example.com/path
https://example.com/path1/path2
https://example.com/path1?test=123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);