re = /^https?:\/\/[^\/]+\/?(\?.*)?$/m
str = 'http://example.com
https://example1.com
https://example2.com/
http://anything.com/?test=12
http://anything.com?test=12
http://example.com/path
https://example.com/path1/path2
https://example.com/path1?test=123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end