const regex = /^https?:\/\/[^\/]+\/?(\?.*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^https?:\\\/\\\/[^\\\/]+\\\/?(\\?.*)?$', 'gm')
const str = `http://example.com
https://example1.com
https://example2.com/
http://anything.com/?test=12
http://anything.com?test=12
http://example.com/path
https://example.com/path1/path2
https://example.com/path1?test=123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}