// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^https?:\/\/[^\/]+\/?(\?.*)?$").unwrap();
let string = "http://example.com
https://example1.com
https://example2.com/
http://anything.com/?test=12
http://anything.com?test=12
http://example.com/path
https://example.com/path1/path2
https://example.com/path1?test=123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}