using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\d]+[\s][\w]+[\s^][\w]+\.?";
string input = @"This is a test of my regular expression.
Well.
123 Main Street.
150 Stupid fart.
Saucy Noob.
123 fuk
123 Fruity Licker
Lol.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}