re = /[\d]+[\s][\w]+[\s^][\w]+\.?/
str = 'This is a test of my regular expression.
Well.
123 Main Street.
150 Stupid fart.
Saucy Noob.
123 fuk
123 Fruity Licker
Lol.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end