package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\d]+[\s][\w]+[\s^][\w]+\.?`)
var str = `This is a test of my regular expression.
Well.
123 Main Street.
150 Stupid fart.
Saucy Noob.
123 fuk
123 Fruity Licker
Lol.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}