import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\d]+[\\s][\\w]+[\\s^][\\w]+\\.?";
final String string = "This is a test of my regular expression.\n\n"
+ "Well.\n\n"
+ "123 Main Street.\n\n"
+ "150 Stupid fart.\n\n"
+ "Saucy Noob.\n\n\n"
+ "123 fuk\n\n\n\n\n\n"
+ "123 Fruity Licker\n\n"
+ "Lol.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}