const regex = /[\d]+[\s][\w]+[\s^][\w]+\.?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\d]+[\\s][\\w]+[\\s^][\\w]+\\.?', 'g')
const str = `This is a test of my regular expression.
Well.
123 Main Street.
150 Stupid fart.
Saucy Noob.
123 fuk
123 Fruity Licker
Lol.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}