# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*(Andalucia).*$
/\1 /gm;t' <<< "04001#Almeria#Almería#AL#Andalucia#AN#ES
04002#El Palmer#Almería#AL#Andalucia#AN#ES
0400#Almeria#Almería#AL#Andalucia#AN#ES
04003#Almeria#Almería#AL#Andalucia#AN#ES
04004#Almeria#Almería#AL#Andalucia#AN#ES"