# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"^.*(Andalucia).*$\n\n\n\n\n\n")
test_str = ("04001#Almeria#Almería#AL#Andalucia#AN#ES\n"
"04002#El Palmer#Almería#AL#Andalucia#AN#ES\n"
"0400#Almeria#Almería#AL#Andalucia#AN#ES\n"
"04003#Almeria#Almería#AL#Andalucia#AN#ES\n"
"04004#Almeria#Almería#AL#Andalucia#AN#ES")
subst = "\\1 "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.